elasticsearch

Combo & ICU analysis plugins

Sometimes it's hard to get plug-ins work. If you need elasticsearch installation which works with the ICU and Combo analysis plug-in, try the following:

  1. wget https://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-0.20.6.deb
  2. sudo dpkg -i elasticsearch-0.20.6.deb
  3. cd /usr/share/elasticsearch/
  4. sudo bin/plugin -install com.yakaz.elasticsearch.plugins/elasticsearch-analysis-combo/1.2.1
  5. sudo bin/plugin -install elasticsearch/elasticsearch-analysis-icu/1.7.0
  6. sudo service elasticsearch restart

Please note that the combo plug-in does not work with the recent version (0.90.0) of elasticsearch.
https://github.com/yakaz/elasticsearch-analysis-combo/issues/6

Tags: 
elasticsearch
setup
combo
icu
analysis
plugin